INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Configuring Outgoing E-mails?

Configuring Outgoing E-mails?

(OP)
I'm trying to configure outgoing e-mails on our SBS to point to MessageLabs for virus scanning, but I'm having problems. I don't know if there a really quick way of doing it, because I literally just need everything outgoing to point to one address, but based on the guide on the MessageLabs site, I'm going through the Internet Mail Wizard from the Exchange System Manager. But when I select to configure 'Send Internet e-mail' I'm given the error "To send internet e-mail, the selected server cannot be a bridgehead server".

Is there something I need to do to get this working? I'm completely stuck and google doesn't appear to offer much assistance...


Thanks for any help!

RE: Configuring Outgoing E-mails?

If you're really on an SBS server, you should just do the Internet and Email Setup wizard in the SBS Server Manager console and set up the MessageLabs server as a smarthost.

Dave Shackelford
Shackelford Consulting

RE: Configuring Outgoing E-mails?

(OP)
I tried adding a smarthost using this MS guide (http://support.microsoft.com/kb/821911) but according to my gmail e-mail headers the e-mail is still only being sent from our servers and not through MessageLabs. After entering the approriate server name in the smart host field I applied all settings, but does it require a server restart?

With a smarthost will mail *always* be forwarded to MessageLabs first?


Thanks for any help...

RE: Configuring Outgoing E-mails?

A couple of things. First, admin like a pure Exchange Server. It is one, for the most part, but the wizards have been set up to make things easier and to keep several moving parts in sync. You were asking for a "really quick way of doing it" and it's in the wizard.

Second, MessageLabs may require an SSL connection or authentication, and the KB article doesn't tell you to do that. I think the wizard may give you the option to supply creds. Skim the MessageLab docs again and see if it mentions authentication. I use several different outside mail scrubbing vendors and none require authentication.

Third, using a smarthost will still allow your server's name to show up in the header, it will just add an additional header for the smarthost, so you should see both MessageLabs and your server's name in the header when the email goes out. If your server is having trouble authenticating or reaching MessageLabs, then it will send the mail out on its own, but it will ALWAYS send to the smarthost first.

Check your Application log for errors related to relaying through the MessageLabs server. If there aren't any, go into the Exchange Admin, get properties on the Servername, and go to the Diagnostic Logging (or Monitoring?) tab. From there pick MSExchangeTransport on the left and turn SMTP Protocol Logging on Maximum on the right. Send out some more mail and check your App log again to see what activity was generated.

You may see that MessageLabs is rejecting the attempt to relay, in which case you will need to communicate with them and make sure that your sending IP is in their database. They will usually need that to allow outbound mail from you.

Dave Shackelford
Shackelford Consulting

RE: Configuring Outgoing E-mails?

Hi guys.

OTMC, did you get your SBS -> Messagelabs workded out? I just had exactly the same issue and figured it out.

On one of my standard Exchange servers we use messagelabs too and the Smarthost is specified in the virtual server under the Servers | server | protocols | SMTP section, but in the SBS Exchange it doesnt quite work that way for me. I set the smarthost that way but it just would not route the traffic through ML.

After faffing around a bit and almost opening a support ticket with Messagelabs, I found the answer. I looked under Connectors | SmallBusiness SMTP Connector.. and Voila! unde rthe General tab you specify the Smarthost. See the screenshot at the bottom of this post or at http://41point2.blogspot.com/2008/02/messagelabs-smarthost-in-small-business.html

Why can't they (Messagelabs) have nice clear documentation on their website?

Anyway, I hope that helps.

Cheers
Jake

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close