INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Communication for Clipper application and COM1 not possible under XP

Communication for Clipper application and COM1 not possible under XP

Communication for Clipper application and COM1 not possible under XP

(OP)
Hello All,

I've experienced problems with communication between Clipper application and COM1 port on Windows XP system. For Windows 98, it was working fine, while for XP, COM1 is not responding. I dont know, how to overcome this problem, should I change the code or tailor System set-up ? Could you please help me, as I dont feel knowledgeable enough to handle this problem by myself.

Thanks a lot in advance,

Pawel Jablonski    

RE: Communication for Clipper application and COM1 not possible under XP

Your comms lib is probably directly accessing the COM1 hardware, wich is allowed on Windows 9x, but not on any of the NT based Windows, like Windows 2000 and later (excluding ME).
You should probably update your comms lib, or replace it with something else.
When replacing, considder to also 'upgrade' to Harbour-project or xHarbour compiler, to get a native 32 bit version of your Clipper app winky smile

HTH
TonHu

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close