Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Error log: File does not exist: HNAP1 and TEADevInfo

HeatherFeuer (TechnicalUser) (OP)
8 Nov 07 15:55
I have been attempting to upgrade my local server to PHP5 and MySQL 4.1.x to match the configuration on my new remote server. My local setup is on WinXP SP2: Apache 2.0.54/Perl 5.8.6.811/PHP 5/MySQL 4.  The root path to the server is e:\webserver\apache2; the path to PHP is e:\webserver\php.  I have PHP installed as an Apache module.  Both Apache and MySQL are running as a Windows service.

Even though I have MySQL installed and the correct directives in PHP, when I run phpinfo(), MySQL doesn't show up and I get the following errors when we restart Apache:

CODE

[Thu Nov 08 15:04:31 2007] [notice] Parent: Received restart signal -- Restarting the server.
[Thu Nov 08 15:04:31 2007] [notice] Child 616: Exit event signaled. Child process is ending.
[Thu Nov 08 15:04:31 2007] [notice] Apache/2.0.54 (Win32) PHP/5.2.4 configured -- resuming normal operations
[Thu Nov 08 15:04:31 2007] [notice] Server built: Apr 16 2005 14:25:31
[Thu Nov 08 15:04:31 2007] [notice] Parent: Created child process 3740
[Thu Nov 08 15:04:32 2007] [notice] Child 616: Released the start mutex
[Thu Nov 08 15:04:33 2007] [notice] Child 616: Waiting for 250 worker threads to exit.
[Thu Nov 08 15:04:33 2007] [notice] Child 616: All worker threads have exited.
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_gd2.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_iconv.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_ldap.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_mbstring.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_mysql.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_openssl.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_pdo_mysql.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_soap.dll' - The specified module could not be found.\r\n in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'E:\\Webserver\\PHP\\php_xmlrpc.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Thu Nov 08 15:04:33 2007] [notice] Child 3740: Child process is running
[Thu Nov 08 15:04:33 2007] [notice] Child 3740: Acquired the start mutex.
[Thu Nov 08 15:04:33 2007] [notice] Child 3740: Starting 250 worker threads.
[Thu Nov 08 15:15:34 2007] [error] [client 192.168.2.120] File does not exist: E:/Websites/Apache/HNAP1
[Thu Nov 08 15:15:37 2007] [error] [client 192.168.2.120] File does not exist: E:/Websites/Apache/TEADevInfo

The client IP referenced is one of the other machines on the LAN.  I have found references to TEADevInfo as being something to do with DLink, but our router is a LinkSys.  However, we were using a DLink, but were having problems with it.

I'm stumped.  Short of completely uninstalling everything and starting over, can someone help me figure out what I may be doing wrong?

Thank you!!

Heather
http://www.uniquelyyourshosting.com

lakata (Programmer)
12 Feb 08 16:47
HNAP = Home Network Administration Protocol
TEADevInfo = a firmware file on DLink routers

The source of the requests is a program called "Network Magic" which is bundled with DLink routers. Apparently, this program scans all IP addresses on the LAN, looking for DLink routers.

My traffic looked like this, FYI.

INFO: [10.1.60.147]: "GET /HNAP1/ HTTP/1.1
INFO: [10.1.60.147]: "Accept:
INFO: [10.1.60.147]: "User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Win32)
INFO: [10.1.60.147]: "Host: 10.1.60.154
INFO: [10.1.60.147]: "Connection: Keep-Alive
INFO: [10.1.60.147]: "Cache-Control: no-cache
INFO: [10.1.60.147]: "Pragma: no-cache

INFO: [10.1.60.147]: "GET /TEADevInfo/ HTTP/1.1
INFO: [10.1.60.147]: "Accept: */*
INFO: [10.1.60.147]: "User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Win32)
INFO: [10.1.60.147]: "Host: 10.1.60.154
INFO: [10.1.60.147]: "Connection: Close
INFO: [10.1.60.147]: "Cache-Control: no-cache

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close