Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

amatuer (Programmer) (OP)
22 Mar 07 17:19
Hello all--

I am using an MS Access Project (.adp) and connecting to an MSDE database.

I have an issue with a report which contains multiple subreports.  The record source for the main report is based off of a stored procedure.  Each subreport also uses a different stored procedure.

When I launch the main report, I am prompted to enter a parameter value for the main report and all of the subreports.  So, if I have a report that has 5 subreports, I will be prompted for a value 6 times.  

I would like the ability to enter the parameter once for the main report and then have it applied to the parameters of the subreports.

If someone out there knows how to make this work, please help!!! as I'm at the end of my rope with this report.

Much Thanks.

An Amatuer
PWise (Programmer)
26 Mar 07 14:15
if all the subreports are in the same section then
make sure that the parameter in all the stored procedures have the same name
i.e. @Customerid

place a text box on the report that the control source has the same name as the parameter  without the @
Customerid

put the parameter  in the select statment of the main stored procedure @Customerid as Customerid if you not alreday  Selecting this value
amatuer (Programmer) (OP)
4 Apr 07 15:52
Hey pwise,

Sorry for the late response on this thread.  I had to put this project on the back burner as some other project took precedence (You know how that goes).

Anyway, I followed the steps you provided and the report works like a charm.  

I do want to thank you for providing some much needed insight.

Amatuer

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close