INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Faulting application NTDBSMGR.EXE

Faulting application NTDBSMGR.EXE

(OP)
We just installed a new Windows 2003 server and I'm continuously getting errors in the event log. We are running Pervasive.SQL 2000i (betrieve). The error is: Faulting application NTDBSMGR.EXE, version 7.90.230.36, faulting module w3odbcei.dll, version 7.90.230.36, fault address 0x000348d5. If I stop and restart the Pervasive services on the server or Macola application will begin to work again. Any ideas what's causing this it is stopping the company from running too frequently.....

Thanks!

RE: Faulting application NTDBSMGR.EXE

THat's a fairly old version of PSQL.  There was an SP4 (V7.94).  You'd want to check with Macola to see if they will support and provide the update because Pervasive doesn't support PSQL 2000 any more.  
Back to the actual problem, can you make the fault happen?  If so, what in terms of PSQL is occurring when it happens?

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
http://www.mirtheil.com

RE: Faulting application NTDBSMGR.EXE

(OP)
That is the problem that there isn't any support for it anymore. No, I can't seem to make the fault happen either. I've tried and can't seem to will it to happen. I do have a bunch of MS Access programs that hit the Macola database for information through ODBC links, could they be causing it somehow? Is the "faulting module w3odbcei.dll" have anything to do with ODBC?

RE: Faulting application NTDBSMGR.EXE

W3ODBCEI.DLL is the ODBC driver for PSQL.
If Macola doesn't support PSQL 2000 anymore, do they support newer versions (V8 or V9)?  2000i is old enough that patches aren't available from Pervasive any more.  V8 is about to go unsupported (December 31, 2006) and V9 is the only supported product from Pervasive.  
I don't remember anything like what you are describing but it's been a while since I've worked with PSQL 2000.  

Mirtheil
Certified Pervasive Developer
Certified Pervasive Technician
http://www.mirtheil.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close