INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

ERROR 35 RUNNING CLIPPER UNDER WINXP

ERROR 35 RUNNING CLIPPER UNDER WINXP

(OP)
Three weeks ago my Computer running WIN XP Professional had a disk crashed. All my files were restored successfully.  I have several Clipper applications that were runing fine and now I get the message "Error [35] General protection fault in [my clipper.exe]" If I run these applications in another computer (WIN XP Prof.) they run without any problem.  I have used command and cmd getting the same result.  I have checked Config.nt and Autoexec.nt and they seem to be OK (see below). I do suspect that this problem is related to the parameters that manage memory in DOS that were not set when WINXP was installed and have no idea how to go about it. Any help is appreciated.

CONFIG.NT
dos=high,umb
device=%SystemRoot%\system32\himem.sys
file=40

AUTOEXEC.NT
lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
SET BLASTER=A220 I5 D1 P330
PATH C:\;C:\WINDOWS\SYSTEM32;\C:\WINDOWS\SYSTEM32\COMMAND;C:\DRIVED\CLIPPER\BIN
SET CLIPPER=F75:E000
SET LIB=C:\DRIVED\CLIP53\LIB
SET INCLUDE=C:\DRIVED\CLIP53\INCLUDE
SET OBJ=C:\DRIVED\CLIP53\OBJ
SET PLL=C:\DRIVED\CLIP53\INCLUDE
SET PIPEHANDLE=0

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

Did you type over the stuff from config.nt or is there just a typo of

CODE

file=40
where there should really be

CODE

files=40
?

And btw, a value of > 100 would be a much safer setting, IMHO, as opening a few databases with indexes count up quickly over 40.
Also the line

CODE

set CLIPPER=F75;E000
indicates a higher value might be required.

HTH
TonHu

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

(OP)
TonHo,
Thank you. I changed the files to 100 and nothing changed.
Also, the punctuation in set clipper you had a ";"  Is that supose to be a ":" ?

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

regava,

There should be a ";" between parameters in the SET CLIPPER line.  TonHu had it right and the files should be at least 100.  Did you change the syntax of the line as TonHu suggested and bump it to 100.  Then did you reboot or just try it and see what happens, definitely reboot, ut make sure that you have raised the parameter to 100 and make sure that it is FILES=40 and not "FILE".   Make sure that FILES=100 & F100 in the SET CLIPPER are set the same.

Jim C.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

(OP)
TonHu and Jim C.,
Thank you for your response. I set everything as indicated, rebooted the PC, and got the same result. Any other suggestion?  I am reaching the end of the rope.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

regava,

Try updating the exe itself, incase it's corrupt?  Copy a clean copy of the exe and see if that makes any difference.
Anytime I have gotten a GENERAL PROTECTION FAULT, it was from a bad EXE.

Jim C.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

(OP)
Jim C.,
Thanks again. I can use the same EXE in a different computer and it works fine. Also, when I tried to compile the .PRG I get the same error message when the link is run.
I do not know what to next short of reinstalling WINDOWS.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

regava,

Let's look at what we know, the exe is fine.  The general protection fault is coming from BLINKER and not Clipper specifically.  The GPF error is a catch all error, and doesn't address a specific problem, but any one of a number of unspecified problems.  The EXE works fine in other environments but not his machine.  The files parameter & the SET CLIPPER shouldn't be an issue with this type of error.  Something is working differently than before, can you run down all of the changes to this machine.  New HD or just formatted?   There must be something working differently now than before,  try to isolate each thing that was done and see if any of these could be the source of problem.

Jim C.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

I noticed that you have your Clipper 5.2 and your Clipper 5.3 stuff mixed together.  Was this intentional or what?  Also, do you use Blinker, as your path statement doesn't show?  What version? And if this is a 5.3 program, are you using the Blinker in protected mode?

Regards,
David.

RE: ERROR 35 RUNNING CLIPPER UNDER WINXP

(OP)
I found the solution.  When WIN XP was reinstalled in my computer SP2 was not part of it.  Yesterday SP2 was installed and everything is working fine.
I want to thank all of you who put so much work in trying to help me. I am forever grateful for your effort.
Once again, Thank you and have a wonderful day.

Regava.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close