Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Failed to login to BrightStor ARCserve Backup database.(EC=-2005)

chams123 (MIS) (OP)
22 Aug 06 16:14
Since last week, have started to see after a Successful Backup Operation the message: CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005).  Then the database becomes unavailable, the Database Engine shuts down and then stops.  Am having to restart the database engine manually after that.  And, then last night, the backup failed due to the following: Mount media request cancelled by user or by default timeout.  Not sure if the two are related or not.  

I do not know what to do in order to fix the Database engine problem or the failure to login to the ARCserve Backup database.  
davidmichel (TechnicalUser)
23 Aug 06 12:04
Try deleting the ARCserve\Database\r*.* files first.
chams123 (MIS) (OP)
23 Aug 06 14:34
What would the deletion of those files do?
vschumpy (Instructor)
24 Aug 06 4:37
This and many other problems and resolutions for those problems are described in this document:

http://supportconnect.ca.com/sc/redir.jsp?reqPage=search&searchID=TEC376895
chams123 (MIS) (OP)
24 Aug 06 10:20
Found some info in CA Tech Document ID: TEC389855 and performed the following steps: (1) Deleted three files in the \database directory: rdm.chk, rdm.chi, and raaaaaa.chg. (2) Checked the value of the AsyncRead value in the Velocis.ini file.  Was already set to 0.  (3) Added the following registry value: HKEY_LOCAL_MACHINE\SOFTWARE\ComputerAssociates\Brightstor ARCserve Backup\Base\Database  Debug  REG_DWORD  4  (4) Restarted the Database Engine.  (5) Ran a Backup.  

The backup has finished now.  Problem still exists.  

Job Activity log shows this after the Successful Backup:

Information        08/24/2006 10:05:34 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 10:05:34 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 10:05:34 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 10:03:34 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 10:03:34 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 10:03:34 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 10:02:59 AM                   [JOBQUEUE]: Status changed from Active to Ready [Job No: 1] [Description: Backup Full]
Information        08/24/2006 10:02:59 AM                   [JOBQUEUE]: Rescheduled for  8/25/06 at  8:09 AM [Job No: 1] [Description: Backup Full]
Information        08/24/2006 10:01:34 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 10:01:34 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 10:01:34 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:59:34 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 09:59:34 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 09:59:34 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:57:34 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 09:57:34 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 09:57:34 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:55:56 AM                   [DBeng] Killed RDS process (PID=9744)
Information        08/24/2006 09:55:56 AM                   Database Engine is Stopped.
Information        08/24/2006 09:55:56 AM                   Database Engine is shutting down.
E5110              08/24/2006 09:55:56 AM                   The database is no longer available.
Information        08/24/2006 09:55:56 AM                   [ASDBAPI] Fail to DB login machine:FHFCU-SBS, Error Code:-2005
Information        08/24/2006 09:55:56 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:55:36 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 09:55:36 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 09:55:36 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:53:46 AM                   [ASDBAPI] Fail to DB login machine:FHFCU-SBS, Error Code:-2005
Information        08/24/2006 09:53:46 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12
Information        08/24/2006 09:53:36 AM                   CAT Failed to login to BrightStor ARCserve Backup database.(EC=-2005)
Information        08/24/2006 09:53:36 AM                   [ASDBAPI] Fail to DB login machine:, Error Code:-2005
Information        08/24/2006 09:53:36 AM                   [ASDBCLI2] s_login failed, ret=-2005, Retry:12


What do I need to do???
chams123 (MIS) (OP)
24 Aug 06 10:26
Also, before I performed the above steps, I did try to re-initialize the database - just astpsdat.  I received the following message: Failed to initialize database(asjob).  Please close all other Brightstor ARCserve Backup Applications and try again.  But, as far as I could tell, there were no other Brightstore ARCserve backup applications running.  Thought it might be the Job and/or Tape Engines, so stopped those and tried again.  Received the same message.  Why wouldn't the initialize work?
Flipper01 (MIS)
11 Sep 06 10:03
Chams123,

I am experiencing the same problem (BAB 11.5 Windows), with the same symptoms and error codes.
Suddenly, a number of BU sessions did not merge into the DB after the BU. Now, none of the sessions merge into the DB.
I am running a DBcheck on the astpsdat DB, but this takes some time. Have you found the solution in the meantime ?

Thanks
vschumpy (Instructor)
11 Sep 06 10:50
The solution is preventative maintenance - as per the techdoc, reactive maintenance is nearly always going to take longer.
chams123 (MIS) (OP)
11 Sep 06 12:55
Flipper01,

Yes, was able to fix the problem with some CA Tech Support help.  Here are the steps that we went through along with the info we learned in the process:

From the command prompt:
>cd prog*\ca\bright*
>cstop

In the C:\Program Files\CA\BrightStor ARCServe Backup our Temp folder had 66,771 files in it. Files are written to the TEMP folder during the backup and then written to the database after the backup is complete.  Because it was so large, it had to be cleaned out manually.  Only once the Temp folder is cleaned out will the database be able to be written to.  Renamed current Temp folder to TempOld and deleted entire TempOld folder.  The backup process usually clears the Temp folder itself.  Temp folder should always be empty after a successful backup.

From the command prompt:
>cd prog*\ca\bright*
>cstart

After the above process, the database was still "no longer available" after the backup.  Called CA Tech Support again - different person.  He had us do the following:

He sent us a zip file of a new set of databases.  He renamed the DATABASE folder in C:\Program Files\CA\BrightStor ARCServe Backup to DATABASEold and created a new DATABASE folder.  He then extracted all the new database files into it.  Did a test backup and the database was now good.

He suggested that we run a check against the database every 1-2 weeks.

From the command prompt:
>cd c:\
>cd prog*\ca\bright*
>dbcheck -a -L casdb;admin;secret astpsdat

Hope that helps!!!
Flipper01 (MIS)
11 Sep 06 14:13
Hey Chams123,

I will give it a try.
In the meantime, I launched dbcheck -a -L casdb;admin;secret astpsdat, - saw some errors displayed -but it still was running after a few hours...Whenever this process has finished, I can proceed with the solution CA gave to you.

Thanks so far !
vschumpy (Instructor)
11 Sep 06 15:37
All of this is listed in the techdoc here:

http://supportconnect.ca.com/sc/redir.jsp?reqPage=search&searchID=TEC376895

Including that dbcheck is pretty much a wasted effort if you know you have problems as it only tells you it has problems and does nothing about it.
Flipper01 (MIS)
13 Sep 06 8:18
Guys,

I have the BAB 11.5 working again.
I had to reinitialize the database.(Start, Programs, Brightstor, Server Admin, database tab, select astpsdat)
VSchumpy : ran the dbcheck utility just to make sure it was the astpsdat db that was having the problem. Dbcheck results showed db inconsistencies - dbcheck can take some time !
Chams123 :
Tried removing the contents of the temp dir -> same problem
Tried keybuild utility ->same problem
Then tried reinitialize astpsdat.db (! first : put all jobs on hold and close all GUI, except server admin)-> successful !

Thanks for the tips !

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close