Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

byrne1 (Programmer)
11 Aug 06 15:01
I have a Winterm terminal with a printer attached and I would like to add this printer to my Server 2003 box.  According to what I have read on the internet, I have to add an LPD port to my server, but I do not have LPD listed as a port option (I do have Localport, print server, and standard tcp/ip port).

I cannot find any information on how to set up TCP/IP printing on 2003 (which is what is supposed to create the LPD port???).

Any ideas?
wdoellefeld (TechnicalUser)
11 Aug 06 16:54
It's a windows component.

Add remove programs >>add remove win components >> Other network file and print services >> Print services for UNIX

Creates a service called "TCP/IP print server" which is dependant on the print spooler service. The option should become available then.

On a side note, I had a fun time trying to get local printers on my winterms to work.

(yay! shameless advertising. my side business)
http://www.frcp.net

byrne1 (Programmer)
11 Aug 06 17:12
Thanks!  I was able to add the print services for UNIX and was (I think) able to set up the printer.  But, as you alluded to in your post, I cannot print to the local winterm printer.  How did you finally do it?
wdoellefeld (TechnicalUser)
11 Aug 06 17:34
These winterms are tricky.

For example, if the host name of my wyse is WT000000 and the name of the print queue I want is HP_4200.

On the winterm, in printers setup, you only want to configure the local tab, leave network alone (blank, no settings whatsoever). Set the both printer name and printer identication as "HP_4200" (same name as the queue on the server). Check both enable boxes for printer and LPR.

On the server, create the LPR port;
Name of server providing lpd: WT000000 (my terminals are not static)
Name of printer or print queue on server: HP_4200

(yay! shameless advertising. my side business)
http://www.frcp.net

byrne1 (Programmer)
11 Aug 06 17:41
Well, that is just what I did but it still does not print.  When I click OK to creat the LPR port, I get this error message:

The server name you specified could not be resolved.

My server name is MBWATCH, my printer name is MBWATCH CUT.

wdoellefeld (TechnicalUser)
12 Aug 06 23:31
Sounds as if the terminal is not registered in dns. Can you ping it at all?

(yay! shameless advertising. my side business)
http://www.frcp.net

byrne1 (Programmer)
14 Aug 06 10:43
Nope, not at all.  I've set the terminal up to obtain an IP automatically from the DHCP server and it (the terminal) says it has an IP of 10.10.10.210.  But when I look at the address leases on my DHCP host I do not see one for 10.10.10.210.
wdoellefeld (TechnicalUser)
14 Aug 06 15:39
Thats odd. You do have a 10.10.10.x subnet setup in your scope right? Assuming you tried setting static, restarting, and changing back to dhcp. Checking cables, etc, all the usual stuff. Have you tried flashing the firmware on the terminal at all?

(yay! shameless advertising. my side business)
http://www.frcp.net

byrne1 (Programmer)
14 Aug 06 15:42
Yes, I do have the subnet setup in the scope.  I have also set to static, restarted, and reset to dhcp, restarted, but to no avail.  The cables are intact (I can ping anything on the network from the terminal).

Sorry, but what do you mean "flashing the firmware"?  Is this something that involves a long trench coat?  LOL
wdoellefeld (TechnicalUser)
14 Aug 06 16:21

Quote:

Is this something that involves a long trench coat?  LOL
Well you could try that. Scare it into submission :)

I guess I should ask what model of winterm you have. Most of them are running either a blazer OS (base models) or WinPE midrange+ models) on firmware. Was curious if reloaded/upgraded that base firmware image at all. Not easy to do without network.

All I can say is pour settings and make sure they are correct and probably call Wyse. I've received bad terminals in the past with weird problems and they have been decent about replacing them.

(yay! shameless advertising. my side business)
http://www.frcp.net

byrne1 (Programmer)
14 Aug 06 16:30
Well, it's a relatively new 1125SE.  It came to me from my consultant in used condition (he pulled it out of another client's network and is letting me play with it for a while).  I have not updated the firmware on it.

BTW, I tried flashing the terminal but all I got was weird looks by my coworkers. :)
byrne1 (Programmer)
25 Aug 06 15:46
I always forget that Linux, even Linux print drivers for Windows, is ALWAYS case sensitive!!!

I had the incorrect case in the port on my Windows server.  As soon as I changed that it started working!!

gO fIguRe  :)

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close