Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

How do I code Tear-off in ZPL II?

ZPLprogrammer (Programmer) (OP)
19 Jul 06 17:55
Can't seem to get the cutter to move to desired position.  Can set printer config. manually but want to include the tear-off as part of the label format.  Trying the TA but not having any success.  Any ideas?
jlasman (TechnicalUser)
19 Jul 06 19:39
It the ~TA command isn't working for you, do you perhaps have the ^XB command in force that suppresses backfeed?

If so try removing ^XB and see if your problems go away.

Jim Asman
http://www.spectracolorservices.com

ZPLprogrammer (Programmer) (OP)
20 Jul 06 9:16
No, no XB present.  Here's the code I'm trying to no avail.  Note the TA+56.  

~CC¬                                      
¬XA¬JMA¬FS¬XZ                             
¬XA¬SS,,,0870¬FS¬XZ                       
¬XA¬MTT¬FS¬XZ                             
¬XA¬MNW¬FS¬XZ                             
¬XA¬MMC¬FS¬XZ                             
¬XA¬TA+56¬FS¬XZ                           
¬XA¬MD+19¬FS¬XZ                           
¬XA¬LT-64¬FS¬XZ                           
¬XA¬PRB¬FS¬XZ                             
¬XA¬IDR:*.LGO¬XZ                          
¬XA¬IDR:*.*¬XZ                            
¬XA¬MCY¬XZ                                
¬XA¬LH0000,0000¬FS¬PON¬FS                 
¬FO0021,0411¬A0N,0041,0051¬FDSize :¬FS    
¬FO0033,0531¬A0N,0028,0030¬FDDpt/Cl¬FS    
¬FO0318,0531¬A0N,0028,0030¬FDSeason¬FS    
¬ISLB,N¬FS¬XZ¬XA¬MCY¬XZ¬XA¬ILLB¬FS                        
¬FO0000,0000¬AAN,0000,0000¬FD ¬FS                         
¬FO0057,0270¬BY4,2,100¬BUN,0090,Y,N,Y¬FD007311040351¬FS   
¬FO0021,0195¬A0N,0041,0051¬FDDB-142 SMART XX¬FS           
¬FO0018,0234¬A0N,0041,0051¬FDBLUE CHECK PATT¬FS           
¬FO0138,0411¬A0N,0041,0051¬FD16.5 34¬FS                   
¬FO0282,0792¬A0N,0057,0068¬FD29.99¬FS                     
¬FO0039,0654¬BY2,2,100¬BCN,0090,N,N¬FD900780100005950¬FS  
¬FO0045,0495¬A0N,0028,0030¬FD0781¬FS                      
¬FO0351,0492¬A0N,0028,0030¬FDE3¬FS                        
¬PQ0001,0000,0000,N¬FS¬MCN¬XZ                                     
jlasman (TechnicalUser)
20 Jul 06 9:56
I'm not sure what the punctuation character is before each command as displayed here. Make sure you are using ~TA with a tilde in the real file.

The only thing that comes to mind is that you may have to pad the distance with a 0 to make it 3 digits, So try...

~TA+056

or

~TA056

Maybe it doesn't like the "+"

Jim Asman
http://www.spectracolorservices.com

jlasman (TechnicalUser)
20 Jul 06 10:53
I just tried ~TA056 on my printer and it advanced the label about 1/4 inch.

Jim Asman
http://www.spectracolorservices.com

ZPLprogrammer (Programmer) (OP)
20 Jul 06 10:58
For some reason, our label software (TL Ashford) replaces the carat with that other character.  I'd actually discovered that I needed a tilde for the TA prior to your reply.

But it was the 3 digits that did the trick.  I just assumed that it was a max of 3 digits, not a requirement.  I saw that other commands worked that way.  But as long as it works, I'm happy.

The resolution was:

¬XA~TA056¬FS¬XZ

Thanks for your help.  You're a genuis!

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close