Member Login

Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

How do I code Tear-off in ZPL II?

How do I code Tear-off in ZPL II?

Can't seem to get the cutter to move to desired position.  Can set printer config. manually but want to include the tear-off as part of the label format.  Trying the TA but not having any success.  Any ideas?

RE: How do I code Tear-off in ZPL II?

It the ~TA command isn't working for you, do you perhaps have the ^XB command in force that suppresses backfeed?

If so try removing ^XB and see if your problems go away.

Jim Asman

RE: How do I code Tear-off in ZPL II?

No, no XB present.  Here's the code I'm trying to no avail.  Note the TA+56.  

¬FO0021,0411¬A0N,0041,0051¬FDSize :¬FS    
¬FO0000,0000¬AAN,0000,0000¬FD ¬FS                         
¬FO0021,0195¬A0N,0041,0051¬FDDB-142 SMART XX¬FS           
¬FO0018,0234¬A0N,0041,0051¬FDBLUE CHECK PATT¬FS           
¬FO0138,0411¬A0N,0041,0051¬FD16.5 34¬FS                   

RE: How do I code Tear-off in ZPL II?

I'm not sure what the punctuation character is before each command as displayed here. Make sure you are using ~TA with a tilde in the real file.

The only thing that comes to mind is that you may have to pad the distance with a 0 to make it 3 digits, So try...




Maybe it doesn't like the "+"

Jim Asman

RE: How do I code Tear-off in ZPL II?

For some reason, our label software (TL Ashford) replaces the carat with that other character.  I'd actually discovered that I needed a tilde for the TA prior to your reply.

But it was the 3 digits that did the trick.  I just assumed that it was a max of 3 digits, not a requirement.  I saw that other commands worked that way.  But as long as it works, I'm happy.

The resolution was:


Thanks for your help.  You're a genuis!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!


Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close