Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Smiler1 (TechnicalUser)
5 Jul 06 19:18
Our Night1 service is currently set to 17:00 to 09:00, I would like to know the command to change this, ie. to 18:00 instead of 17:00, I've got the command prompt and copy commands given in the help index, but it keeps coming back with an error, saying the is a problem with the syntax and puts < > around the message, Could someone tell me the correct commands to change our night1 service timing, Were using rel.6.057?? I think

Thanks !

MitelInMyBlood (TechnicalUser)
5 Jul 06 22:06
Is your system operating 'stand-alone' or is it being managed by OPSMAN?

OPSMAN operates with scheduled tasks to automate the process of invoking night service vs. day service.  

In the absence of OPSMAN the PROGRAMMED SERVICE command is used to set the schedule for day and night service. Here are command examples:

PROGRAMMED SERVICE SCHEDULE NIGHT1 DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE NIGHT1 ON/OFF

PROGRAMMED SERVICE SCHEDULE NIGHT2 DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE NIGHT2 ON/OFF

PROGRAMMED SERVICE SCHEDULE DAY DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE DAY ON/OFF

PROGRAMMED SERVICE SCHEDULE ON/OFF

PROGRAMMED SERVICE DISPLAY

The important thing to remember is the command uses military time (24 hour clock) thus 6 PM is 18:00:00
and you mush specify all 3 parameters, hours, minutes and seconds.
Smiler1 (TechnicalUser)
6 Jul 06 18:53
Thanks for that info, I think I found similar in the online help, but I still have a problem as I have copied and pasted your command in the command box, changing the time to <18:00:00> but a Internet explore box appears to tell me The command text as entered is incomplete, ambigous or incorrect! Click Help for the correct syntax.

<PROGRAMMED SERVICE SCHEDULE NIGHT1 DAILY <18:00:00>>

What am I doing wrong, By the way I am not 100% I am using opsman, But I assume I am as night service is automatically turned and off at set times, and this is the time I am trying to change.

anymore hints or tips would be welcomed !

Smiler
kwbMitel (TechnicalUser)
6 Jul 06 19:29
Assume for a moment that you are entering the command correctly. It may be that the controller is waiting for a response to an earlier command. One way to test this theory is to type a simple command like "WHERE". If this fails then you know you're hooped. You now have to figure out response the system wants. On SX2000's you can type help to break the chain. I haven't figured out anything short of a reboot on the 3300 to end it. If you where recently busying out circuits, one suggestion would be "FORCE". If the "WHERE" command succeeds, assume you are entering the command incorrectly. This command worked for me "prog serv sch night1 daily 17:01"
MitelInMyBlood (TechnicalUser)
6 Jul 06 19:40


Don't use the < > brackets in the command. The brackets are only there for clarity.
Smiler1 (TechnicalUser)
6 Jul 06 19:44
Hi thanks for the response, I have tried the WHERE command and it returns this result.

Welcome to --------User                                                       
Last Login:                                                                     
Number of Unsuccessful Login Attempts:                                          
Last Unsuccessful Login:                                                        
Current session on Main Controller  A   Active                                  
Operating with 3300 ICP Call Control 34.1.0.6

Does this mean the system is operating properly ?

If its any help the command "PROGRAMMED SERVICE DISPLAY" returns the night service settings
PROGRAMMED SERVICE SCHEDULE IS ON                                               
PROGRAMMED SERVICE SCHEDULE DAY IS ON                                           
PROGRAMMED SERVICE SCHEDULED DAY: DAILY 09:00:00                                
PROGRAMMED SERVICE SCHEDULE NIGHT1 IS OFF                                       
PROGRAMMED SERVICE SCHEDULED NIGHT1: DAILY 17:00:00                             
PROGRAMMED SERVICE SCHEDULE NIGHT2 IS OFF                                       
PROGRAMMED SERVICE SCHEDULED NIGHT2: DAILY 18:00:00

But it fails when i try the command changing the time.

Any more ideas ?

Smiler1 (TechnicalUser)
6 Jul 06 19:46
Thanks Mitel, but i have tried all different combinations, with - without !
MitelInMyBlood (TechnicalUser)
7 Jul 06 7:28
Well....
you never completely answered my original question. However, from your lack of any success using the Programmed Service command I will ask you once more, is this system being managed by OpsMan and/or Enterprise Manager?

If you don't know for sure, then from the maintenance terminal enter the command:  IP D D  (note spaces).
What I'm fishing for here is to find out if there is an FTP user name on the system by the name of mnms. The result of entering that command might look something like this:
 
sn(0,0)host:C:\tornado\target\config\mc3e\vxWorks e=10.248.118.32:FFFFFF00 h=10
.1.111.63 g=10.248.118.1 u=mnms pw=MTLPRVPW tn=HARRIS-A


Where you see u=mnms that is the ftp account used by OpsMan. Unlikely that anyone would go to the trouble to program that into your system unless they had a reason to, i.e. for OpsMan. If it IS there then OpsMan is hiding out there in the wings someplace, possibly even at your service provider's office. If OpsMan is managing this system then very likely OpsMan has a scheduled task running that is controlling your Day/Night service.

In any event you should still be able to force the system to change Day/Night service with the command CP SER DAY (to force it to day service). Similarly the commands CP SER NIGHT1 or CP SER NIGHT2 will force it to either night 1 or night 2 service.
Smiler1 (TechnicalUser)
7 Jul 06 12:36
Hi Mitel, thanks for the advice, sorry If i was a bit vague, but did'nt know anything about the opsman ! I know there is no FTP access to the box from the internet if thats any help.

I must be doing something daft, as the command IP D D does'nt even work, and comes back with a similar error message. I cant be entering something so simple wrong can I ? Do you know why this would be or do you have any other sugguestions ?
MitelInMyBlood (TechnicalUser)
7 Jul 06 19:20
If IP D D  (short for IPConfig Debug Display) results in an error message then you definitely do not have OPS MAN because your system does not have the software options to support it.

Try these 2 commands in sequence (note spaces)

PROG  S  S  NIGHT1  D  18  <press enter>
PROG  S  S  NIGHT1  ON   <press enter>
Smiler1 (TechnicalUser)
8 Jul 06 9:44
Hello Again !

That did'nt work either get the same style error message, I copied and pasted from the reply I have even typed it in letter for letter and still errors, I was very careful with the spaces as well.

Is it me ?
MitelInMyBlood (TechnicalUser)
8 Jul 06 11:29
No, it's me. >>sheepish grin<<
1) I neglected to ask a very important question
2) I overlooked something critical in one of your replies

The question I failed to ask was what type of MITEL system you're running. DOH....

However, you inadvertently gave me that answer in one of your other replies and like an idiot, I ignored it too.

From your reply message 6 posts above this one you did a cut 'n paste of something that would have given us a big clue if I had noticed it. Here is the pertinent part of that post:

Current session on Main Controller  A   Active
Operating with 3300 ICP Call Control 34.1.0.6


Gee whiz, you're using a 3300!!
and...you also appear to be using the telnet interface to send your commands directly to the SX2000 call control. That is a very big (huge) "no-no."

The "Business Hours" that you're trying to change is a feature of the MLAA (Auto Attendant) which is a component of the EMEM (Embedded Mitel Express Messenger) - the voice mail system.

To make the change you must either use the System Administration Tool and edit the Business Hours Configuration Form or log into the voice mail Administrator's Mailbox  (call voice mail from any extn, when it answers press * then enter the mailbox number of the system administrator folowed by the password, then press 3)

Smiler1 (TechnicalUser)
8 Jul 06 12:06
Telnet ? no I am using the web interface, then going system administration, then maintenance and diagnostics, then Maintenance commands,  this is correct is'nt it ?

The business hours are not setup in the voicemail section, what benifit would I get setting up the times there ?

Thanks for your ongoing help !

MitelInMyBlood (TechnicalUser)
8 Jul 06 16:54

I believe on the 3300 that's the only place you can do what you're trying to do.  

What does the HELP screen tell you?

Smiler1 (TechnicalUser)
9 Jul 06 9:58
Heres what i've copied off the help from the 3300, but it seems to be exactly what you've said to do. but does'nt work, even copied and pasted from help file to command line just changing the time 18:00:00 !!



PROGRAMMED REBOOT
PROGRAMMED REBOOT COURTESY ON

PROGRAMMED REBOOT COURTESY OFF

PROGRAMMED REBOOT DISPLAY

PROGRAMMED REBOOT RESOURCE RECOVERY ON

PROGRAMMED REBOOT RESOURCE RECOVERY OFF

PROGRAMMED REBOOT RESOURCE RECOVERY <hh:mm:ss>

PROGRAMMED REBOOT SCHEDULE ON

PROGRAMMED REBOOT SCHEDULE OFF

PROGRAMMED REBOOT SCHEDULE <DAILY> <hh:mm:ss>

PROGRAMMED REBOOT SCHEDULE <day-of-week> <hh:mm:ss>

PROGRAMMED REBOOT SCHEDULE MONTHLY <week # [1-4]> <day-of-week> <hh:mm:ss>

PROGRAMMED REBOOT SCHEDULE INTERVAL <interval in weeks [1-52]> <MMM> <day-of-month> <hh:mm:ss>

PROGRAMMED SERVICE
PROGRAMMED SERVICE SCHEDULE NIGHT1 DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE NIGHT1 ON/OFF

PROGRAMMED SERVICE SCHEDULE NIGHT2 DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE NIGHT2 ON/OFF

PROGRAMMED SERVICE SCHEDULE DAY DAILY <hh:mm:ss>

PROGRAMMED SERVICE SCHEDULE DAY ON/OFF

PROGRAMMED SERVICE SCHEDULE ON/OFF

PROGRAMMED SERVICE DISPLAY
MitelInMyBlood (TechnicalUser)
9 Jul 06 11:03
Too much documentation on hand is sometimes worse than not enough. Makes it hard to find things that you know are there.

The programmed service schedule commands are indeed valid for the 3300 starting with release 6 (6.0.5.7) call control rls 34.1.0.6 which is what you're running, so darn it, this is supposed to work.

When entering the Programmed Service Schedule command, try putting spaces between the numeric values and the colons.  i.e. <HH space colon space MM space colon space SS> thusly:

prog  s  sch  night1  daily  18  :  00  :  00

I think that might solve your problem.
Smiler1 (TechnicalUser)
10 Jul 06 18:52
Hallelujah !!!!

SUCCESS !!!

thanks Mitel, just adding a few space did the trick, sounds very wierd, but I've been able to change the night service now !

Thanks for your ongoing help !!!
MitelInMyBlood (TechnicalUser)
10 Jul 06 20:30
Glad we finally figured it out. Sorry for leading you astray. For some strange reason the command interpretor doesn't parse the colons correctly. This aberration is in fact mentioned in the Release Notes (an MS Word file) that accompanies the software, but is not mentioned anywhere in the product update training, tech handbook nor embedded help. Like Mitel says, we've just got to read those RN's winky smile

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close