Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

TCP/IP has reached the limit on concurrent conections, windows xp err.Helpful Member! 

UnknownEntity (TechnicalUser) (OP)
23 Jun 06 7:41
Hi guys,

My LAN connection suddenly drops when I have this message in my event viewer;

Event ID: 4226

TCP/IP has reached the security limit imposed on the number of concurrent TCP connect attempts. The router still stays active. I have to disable then re-enable the lan connection to connect back to the internet. I do a lot of client to server stuff remotely and have azureus running in the background. Any reasoning, ideas or fixes that anyone can suggest?

Any help is greatly appreciated. Thank you.

Drakul.
Helpful Member!  smah (MIS)
23 Jun 06 8:12
Is this really a server OS or is this Windows XP?
UnknownEntity (TechnicalUser) (OP)
23 Jun 06 15:25
It Windows XP SP 2.

satrow (TechnicalUser)
24 Jun 06 8:23
Remove the limit on TCP connection attempts - http://www.speedguide.net/read_articles.php?id=1497

Site for patch - http://www.lvllord.de/?lang=en&url=tools
UnknownEntity (TechnicalUser) (OP)
25 Jun 06 10:26
Hi again,

Tried that, unfortunately the data given from speedguide doesnt match against what i have in my hex or dec notepad. Therefore I cannot edit anything. Any other suggestions ?

Thanks in advanced.

Drakul.
smah (MIS)
25 Jun 06 10:59
The maximum limit for inbound connections on XPPro is 10 and can not be changed.  http://support.microsoft.com/kb/314882/en-us

If you need to maintain more than that, you'll need to use a server OS like Windows Server or Linux.
UnknownEntity (TechnicalUser) (OP)
26 Jun 06 8:52
This is strange indeed. I have been using xp SP2 since its release, which is some time ago now, and I have never come across any limitations like this before. I have 2 other xp sp2 machines and they also have no problems with the connections I make.

Why does XP SP2 allow for some machines to allow without restrictions and others not?
smah (MIS)
26 Jun 06 9:17
No, these simultaneous incoming smb limitations have always applied to xp since the day it was released - 10 for pro, 5 for home.  After doing some research on this, it looks like your error is something else.  I'm not familiar with azureus, but it appears to be a bit torrent client.  Are you actually serving files from your machine?  First, do some thorough AV & spyware scans to make sure the machine isn't infected with something.  That is the real purpose of the security limit that you're seeing.  See also http://blog.davidkaspar.com/archives/2005/04/windows-xp-sp2-and-event-id-4226.php

This appears to be a common error for bittorrent users & google seems to indicate that the patch satrow posted should help.
UnknownEntity (TechnicalUser) (OP)
26 Jun 06 9:38
I am serving no files from my system, I do however do multiple updates sometimes 50 on the go to client machines on client sites. Azureus offers a stronger and more tightened connection than most bit torrent clients to allow multiple installations or downloads of patches for client machines remotely or on the WAN.

Is there any way of testing whether the patch works, I mean to see whether the number incremented from the patch is physically applied to XP subsystem?

This error is causing my LAN to disconnect from my router Netgear dg834 constantly. I have ran ad aware professional any no spyware found. I maintain my syatem on a weekly basis and use diskeeper pro premier ver 10 for my HDs. Clean registry also on weekly basis.

Since this error occured I have disabled Azureus, done a system clean. I have re-applied the patch and increased the 10 connections to 100. I now await the results.

Thanks.

D.
UnknownEntity (TechnicalUser) (OP)
26 Jun 06 10:26
No luck.

I am having to disable the NIC card in device manager and re-enable it to initialise a link to my router. Even right-clicking now on the icon (bottom right on screen) and trying to disable from there has no affect. This is doing my head in lol. Any other suggestions?  Thanks.

Drakul.
smah (MIS)
26 Jun 06 12:58
This seems very strange, your NIC shouldn't hang/lock under these conditions.  Make sure that you have the latest drivers.  The next time it happens, open a command prompt & type ipconfig /all & tell us what you get.
UnknownEntity (TechnicalUser) (OP)
27 Jun 06 6:09
Strange indeed. When i double click on my LAN 2 connection to bring up the sent and recieved bytes, they show the activity to be stationary, no transfer when lan2 connection is dropped from router. When i go to cmd and type in ipconfig /all, the dhcp server, which is also my router addy, is still showing up, after that i tried pinging my router at 192.168.0.1...results were timed out. How can I see the router but not ping it? I have never seen this before.
I pinged the ip addy of the pc itself and that was okay.

Please help! Thanks.

D.
UnknownEntity (TechnicalUser) (OP)
27 Jun 06 6:21
By the way, drivers were a few months old and now updated. Dont understand why i can see the router but not ping it from cmd though. Hopefully drivers will fix the problem.
smah (MIS)
27 Jun 06 6:31
Go into Device Manager & check the properties for your network card.  On the Power Management tab, make sure the power saving setting is not enabled.
UnknownEntity (TechnicalUser) (OP)
27 Jun 06 6:33
Ive checked that already, it wasnt enabled.
LawnBoy (MIS)
27 Jun 06 9:37

Quote (UnknownEntity):

When i go to cmd and type in ipconfig /all, the dhcp server, which is also my router addy, is still showing up...
Dont understand why i can see the router but not ping it.
ipconfig isn't "seeing" anything, it's merely reporting what settings you have. All that means is that at some point you could communicate with the DHCP server, it doesn't mean you can at this moment.

Try another patch cable.

How are you connected to the router? Through a hub/switch? If so try using a different port on the hub/switch.

Sounds to me like you've got a bad physical port, the question is which one is the bad one. Can/have you tried another NIC in the PC?
UnknownEntity (TechnicalUser) (OP)
3 Jul 06 16:51
Just to inform you all that the culprit of this specific problem of disconnection from ROUTER from my LAN was in fact a driver issue. Thank you all.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close