Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

JPaulB (Programmer) (OP)
30 Oct 05 10:44
Hi Folks,

I have just introduced myself to Clipper (v56.3) and would like to experiment with it.
The bad news is that I am using Windows XP as the O/S.
How do I prepare a "Dos Box" to behave properly for Clipper?
Many thanks
Paul
JockMullin (MIS)
1 Nov 05 9:36
Hi, Paul

Take a look at:

Installing Clipper 5.x on Win/XP
thread288-942760

Hwvr instead of editing config.nt or autoexec.nt, in XP:
-right click on My Computer
-click on Advanced tab
-click on Environment Variables button
-add clipper env variable to system or user environment
 (I use F100;E0)
-add path to clipper5\bin to the path variable
-add path to clipper5\lib to the lib variable (or create if not already there)

Then any dos window you open will be configured for clipper.

The above thread also gives references for handling the problem of CPU being maxed out by clipper progs under XP.

Jock
fbizzell (Programmer)
28 Feb 06 17:52
I need the full contents of this thread288-942760  I am trying to configure windows XP to run clipper applications..no go.
JockMullin (MIS)
1 Mar 06 15:20
Hi, fbizzell

Sorry, don't understand - that thread is still available here by clicking on the link in your post.

You can get a lot more info on the issues raised there in Dave Pearson's FAQ in comp.lang.clipper group in Google.

The 3 big problem areas in getting legacy clipper apps to run well under XP are:

- getting the environment set up for compiling and running.
- solving the problem of having the clipper app hog the cpu when awaiting input
- printing

However there are some old .exe's compiled with libraries which will not run under XP without recompilation - if you don't have the source and/or XP-compatible libraries it may not be possible to run them under XP without guesting another OS such as Win 9x or DOS under XP using something like Microsoft Virtual PC.

What problems are you experiencing?

Jock

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close