Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

1601's back to back. Having problems.

darronb (TechnicalUser) (OP)
27 Jul 05 4:02
I have two Cisco 1601 R Routers I am trying to connect back to back.

I have connected the two serial Ports together with what I believe to be the correct cable.

One half of the cable has "DCE" on it. This end of the cable has been plugged into Router1

Below is the configuration of Router one:

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable secret 5 $1$0Hhv$DSlnbAaT3/DG1IOdRilrq0
enable password enable
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.20 255.0.0.0
 no ip directed-broadcast
!
 no ip directed-broadcast
!
interface Serial0
 ip address 172.16.1.10 255.255.0.0
 no ip directed-broadcast
encapsulation PPP
 clockrate 2000000
!
router igrp 100
 redistribute connected
 network 10.0.0.0
 network 172.16.0.0
!
ip classless
!
!
line con 0
 transport input none
line vty 0 4
 password term
 login
!
end

This is the configuration of router 2

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
enable secret 5 $1$CHsr$PLeto/yR9Ob6.jeriPuiV1
enable password enable
!
ip subnet-zero
!
!
!
interface Ethernet0
 ip address 10.0.0.2 255.0.0.0
 no ip directed-broadcast
!
interface Serial0
 ip address 172.16.1.1 255.255.0.0
 no ip directed-broadcast
encapsulation PPP
!
router igrp 100
 redistribute connected
 network 10.0.0.0
 network 172.16.0.0
!
ip classless
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
 transport input none
line vty 0 4
 password term
 login
!
end

The problem I am experiencing in that the Line is UP on both routers but the protocol is DOWN on both routers.

Here is the interface configuration

Serial0 is up, line protocol is down
  Hardware is QUICC Serial
  Internet address is 172.16.1.10/16
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  Last input never, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     204 packets output, 5997 bytes, 0 underruns
     0 output errors, 0 collisions, 68 interface resets
     0 output buffer failures, 0 output buffers swapped out
     134 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

and on router 1 I keep getting the message:-

00:30:14: %QUICC_ETHER-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem

Keep repeating itself every minute.

I have tried cold starting the router (Although I do not know weather this has been successful.

I have also tried HDLC protocol but with no success. I have not tried this on this type of router  before although I have had two 2500 routers talking back to back with similar configuration.

Can anyone help.
ADB100 (TechnicalUser)
27 Jul 05 5:13
There is no particular need to use PPP, set the encapsulation to the default of HDLC (encapsulation hdlc).  It may also be worth setting the clockrate slower - try 64k (clockrate 64000), then increase it.  Make sure the end that has the clockrate command is the one where the DCE end of the cable plugs in.

The %QUICC_ETHER-1-LOSTCARR error is because there is no Ethernet connection on the router.  Either connect a hub or a PC (using a crossover cable) or turn off keepalives on the interface (no keepalive).

Andy
darronb (TechnicalUser) (OP)
27 Jul 05 9:31
Thanks that worked find:

Two more questions

1: How can i make the serial link connect at 2 Meg

2: For some reason I can not ping accross the serial link to an Ethernet port. I can ping from serial port to serial port.

Config same as above

Any ideas

ADB100 (TechnicalUser)
27 Jul 05 14:12
There are 2 issues here.

The WIC-1T modules should happily run at 2Mbps, the limiting factor may be the 1600-series router generating an accurate clock.  As I said try different speeds and see when it stops working.

With regards the IP routing issue:

1. You have the same network on either end of the network -10.0.0.0/8 - so each router will see network 10.0.0.0/8 directly connected.
2. If you change the IP addressing you need to use other classful networks - i.e. 20.0.0.0/8 as IGRP can't handle subnet masks and VLSM's.

Change one routers Ethernet interface to be 20.0.0.10/8 and add it to IGRP (network 20.0.0.0).  Then check the routing tables on each router to make sure you can see all routes (10.0.0.0/8, 172.16.0.0/16 & 20.0.0.0/8)

HTH

Andy
darronb (TechnicalUser) (OP)
28 Jul 05 9:50
Great, All seems to be working. Kept increasing the clock rate and got up to 500000 before failing.

Is there any other configiation I could do on the router to get it up to 2 Meg
ADB100 (TechnicalUser)
28 Jul 05 12:47
No I don't think so.  Why are you so keen to clock it at 2Mbps?  The routers should happily take an external clock at 2Mbps from a Service Provider but I can only assume the internal clock just can't cope at anything over 512Kbps.
Since these are back-2-back I also assume this is just a learning environment, of so don't worry about the speed, the same logic applies whatever the speed.

Andy

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close