Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

"Bonding" two T1's using ppp encapsulation and Multilink interfaceHelpful Member!(2) 

jd6strings (ISP) (OP)
23 Jul 05 14:28
Can anybody provide an IOS config sample for bonding two T1's using ppp encapsulation and a multilink interface?  This is a 2621 running ver 12.3(15).

Here's my running-conf...am I close?

interface Multilink1
 ip address xxx.xxx.xxx.xxx 255.255.255.252
 no cdp enable
 ppp multilink
 ppp multilink group 1
!
interface FastEthernet0/0
 ip address xxx.xxx.xxx.xxx 255.255.255.0
 no ip unreachables
 duplex auto
 speed auto
 no cdp enable
!
interface Serial0/0
 no ip address
 encapsulation ppp
 ppp multilink
!
interface Serial0/1
 no ip address
 encapsulation ppp
 ppp multilink
Helpful Member!  lambent (Vendor)
24 Jul 05 23:07
You also need "ppp multilink group 1" on those serial interfaces.

For the multilink PPP settings, you better ask your ISP so you can match the settings at both ends. If you want to give it a try first, then try to put "ppp multilink fragment disable" on your interface multilink 1.
ITsmyfault (IS/IT--Management)
25 Jul 05 15:11
fwiw
when I have tried MLPPP with T1's it just ate a lot of CPU and did not get me the BW I wanted.. I've had better luck & performance giving each T1 it's own /30, and using per-packet load balancing with CEF. Keeps CPU low and speed is quite good.

For ex:
!
ip cef
ip cef load-sharing algorithm original
!
interface Serial0/0
 description myfirstinterface
 bandwidth 1536
 ip address 192.168.10.2 255.255.255.252
 no ip redirects
 no ip unreachables
 ip directed-broadcast
 no ip proxy-arp
 ip load-sharing per-packet
 no fair-queue
!
interface Serial0/1
 description myotherinterface
 bandwidth 1536
 ip address 192.168.10.6 255.255.255.252
 no ip redirects
 no ip unreachables
 ip directed-broadcast
 no ip proxy-arp
 ip load-sharing per-packet
 no fair-queue
!
hth
Cotton9 (MIS)
15 Dec 05 14:43
We are about to try the load-balancing option as we seem to be having problems with the multilink and VOIP/QOS.

  Here is our config.  No CPU problem we have notices running 12.3 IOS

!
interface Multilink1
 ip address 192.168.117.1 255.255.255.252
 ip route-cache flow
 ip ospf mtu-ignore
 no ip mroute-cache
 load-interval 30
 no keepalive
 no cdp enable
 ppp multilink
 ppp multilink fragment delay 10
 ppp multilink interleave
 ppp multilink group 1
 service-policy output Voice-Policy
!
!
interface Serial0/0:0
 description SubIf to MRR via first T1
 mtu 1524
 bandwidth 1536
 no ip address
 encapsulation ppp
 load-interval 30
 no keepalive
 fair-queue
 no cdp enable
 ppp multilink
 ppp multilink group 1
!

  Me sure to increaes the MTU size if you are running Exachange as will have problems.  The Multilink headers increase the packet size so more fragmentation in needed and windows will not downsize its frames.

   Hope helps,
hinesjrh (MIS)
15 Dec 05 15:16
Has anyone out there had multiple T1's to the internet and only bonded (ppp multilink) some of them and not others on the same router?  Is this possible?

I was asked a question about this scenario.  I currently have three T1's to the internet bonded via ppp multilink and I am quickly adding a 4th and maybe even a 5th.  Take the scenario of currently having 4.5 MB bonded to the internet and someone downloads a 100 MB file.  Do they potentially take the whole 4.5 MB pipe for a period of time and maybe restrict other users in the process?  What if I left the three bonded together but when adding a 4th line I did not bond that with the other three yet run it all through the same router? ponder

Pros?  Cons?
Helpful Member!  rtfmdude (Programmer)
15 Dec 05 16:21
hinesjrh,

The user that downloads a large file will not restrict other users from downloading across the same bundle - that's what weighted fair-queueing is all about. This is on by default.

Frankly, if I had to deal with this same problem, I would simply add the additional T1s to the existing bundle. It simplifies addressing & can better use the bandwidth that you have available.

It is possible to do what you were considering, but it makes addressing/routing funky & unnecessarily complicates the issue.
cormon (TechnicalUser)
15 Dec 05 18:12
Hi Guys,

I am starting to configure a router with two Bri card in it . It currently work with a dialer interface but this only use two of the 4 available channels . I am lead to believe that in order to use 4 channels I need to setup a miltilink interface and then issue the ppp multilink group  under the bri interfaces.

I have two quick question that I need answered.

Firstly do I migrate all the settings from the dialer interface to the Multilink interface and are these all the settings I need ?

Secondly The four channels when setup will dial to Pri on a n alternate cisco router. Is there any changes needed here.

Thanks in advance for your possible answer.....
rtfmdude (Programmer)
16 Dec 05 16:11
cormon,

nah - you don't have to do that. aggregate with a dialer interface. make sure the other side is setup the same way, too(has ppp multilink on). I'll type up a quick example(from memory, there may be mistakes)

(omitting the isdn specific commands)

int bri0/0
encapsulation ppp
ppp multilink
ppp authentication chap
(ppp multi & auth only necessary if you're accepting calls, not just placing them)
dialer pool-member 1
!
int bri0/1
encapsulation ppp
ppp multilink
ppp authentication chap
(ppp multi & auth only necessary if you're accepting calls, not just placing them)
dialer pool-member 1
!
int dialer 50
encap ppp
ppp multilink
dialer pool 1
dialer load-threshold 1 either
dialer-group 1
dialer string XXXXXX
ppp authen chap
ppp chap hostname XXXXXX
ppp chap pass XXXXX
(or ppp pap sent-username XXXX pass XXXXX)
!
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 dialer50

full doc on using dialer interfaces(dialer profiles, different than using a dialer rotary-group)

http://www.cisco.com/warp/public/793/access_dial/ddr_dialer_profile.html

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close