INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

Getting Apache modules ldap and auth_ldap to work on SUSE 9.2

Getting Apache modules ldap and auth_ldap to work on SUSE 9.2

Getting Apache modules ldap and auth_ldap to work on SUSE 9.2

(OP)
Hi

We're trying to get LDAP authentication to work on our Apache server
(running on an installation of SUSE Linux Professional 9.2).
We can see that the modules ldap and auth_ldap are supplied as precompiled
modules in the apache2-prefork folders.
We have enabled the Apache modules in the YAST (in the HTTP Server module
of YAST) and everything seems to work fine - the modules get registrered as
loaded in the /etc/apache2/sysconfig.d/loadmodule.conf once the Apache
server is restarted.

But: as soon as we put some LDAP authentication lines in the
part of the httpd.conf file, we get errors when trying to restart Apache.
We try to insert the following lines in the  part of httpd.conf:

CODE

<directory /srv/www/cgi-bin>
AuthType Basic
AuthName "BackupPC"
LDAP_Server 192.168.1.23
LDAP_Port 389
Base_DN "dc=example,dc=com"
UID_attr uid
AuthAuthoritative on
Require valid-user
</directory>

Restarting Apache with the following lines inserted in httpd.conf gets us the following error:

Quote:


Syntax error on line 213 of /etc/apache2/httpd.conf:
Invalid command 'LDAP_Server', perhaps mis-spelled or defined by a module not included in the server configuration


Hopefully someone out there has a tip to what needs to be corrected/changed?

    Best

    Rasmus Wehner
    ROSA - The Danish Rock Council
    Denmark

RE: Getting Apache modules ldap and auth_ldap to work on SUSE 9.2

That line must be like

ldap://ldap.domain.com:389/dc=domain,dc=com??base?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close