Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

SpeedyGonza (TechnicalUser) (OP)
17 Jul 05 19:02
To start off...I am using Extender 7.5.28, Smartlist Builder 7.5.15 and Great Plains 7.5 SP 6 and SQL Server 7.

In our GP we have several companies...let's call the main one "Company A" and the problematic one "Company B". We also have 2 test servers which are contains a replicate of the database from the live server.

I am having a problem when trying to access
Inquiry > Purchasing > Purchase Order Docs on "Company B" on the live server.

I've entered the Vendor ID, check off all 3 check boxes to view all POs and Receipts entry.
When I've highlighted one of the row and click on the Receipt Number I'm getting:

Unhandled script exception:
Object has no reference.

EXCEPTION_CLASS_SCRIPT_BAD_PARAM
SCRIPT_CMD_DEREF_TABLE

I am not sure what is happening as this is a Great Plains Dexterity error…it has nothing to do with our customized forms / reports / VBA errors.

After testing with different logons, trying the same steps on different machines, I've determined that this script error should have nothing to do with Windows Permission nor GP Permission or specific GP installation files….It should have something to do with the database…. something has changed I don't know what it is.

One possibility is that when I install Extender on the "Company B" it has broke something on the live server.
When we setup "Company A" extender was installed quite earlier on ...we haven't setup extender on "Company B" until just few days ago...there are already lots of POs and Receiving Entry's in the database prior to extender being installed.

But that doesn't quite explain it because I've installed Extender for the "Company B" on 2 test servers and I was still able to do receiving trx inquiry successfully on the test servers. Also, I'm able to do receiving trx inquiry for "Company A" on both the live server and the test servers.

Your comments and advices are highly appreciated.
winthropdc (Programmer)
18 Jul 05 12:08
It is possible that the version of Extender is not compatible with the service pack of Great Plains you have.

Contact eOne for support on this version of eXtender.

David Musgrave [MSFT]
Senior Development Consultant
Escalation Engineer
MBS Support - Asia Pacific

Microsoft Business Solutions
http://www.microsoft.com/BusinessSolutions

Any views contained within are my personal views and
not necessarily Microsoft Business Solutions policy.
This posting is provided "AS IS" with no warranties,
and confers no rights.  

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close