Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

novice05 (IS/IT--Management) (OP)
8 Jul 05 5:57
I am using W2K server with all PS4 and components.
1) I had created a policy in presentation server console, policies, printing/client printers/auto-creation "enabled". Only to "auto-create client's default printer" (citrix have problem when client have more than 3 printers)
2) in ICA connection configuration, Client settings/connection to 'inherit user config's is enabled (this will connect client printers at logon)
3) Citrix hot fix for W2K server for printer is installed.
I still have problem in printer auro-creation. In event viewer,
"Client printer auto-creation failed. The driver could not be installed. "
Can someone point me where did I went wrong please ?
ascotta (Vendor)
8 Jul 05 6:05
You have to have the correct drivers installed on the Citrix servers.

Go onto the console or desktop on server and open printers. Click file and then server properties. Click the drivers tab and add the correct driver.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 6:21
Thanks  a lot Scott.
My problem is that our users are everywhere and they use their client's PC and sometime internet cafe (some sometimes carry their laptop). I don't know what printer they will use and thats why I think about them using autocreated printer, and that printers to be live during the client's session and to remove after they log off. Its now not one printer is autocreated.
Thankie
ascotta (Vendor)
8 Jul 05 6:38
They need to use the Universal print driver then. Can't tell why they are not autocreating.

In your office/place of work are they autocreating ?

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 7:01
We just gave them access to our system (they use phone, email and fax in the past). Admin doc on printing from Citrix is not so complete either.
I have no idea why autocreate not working either.
Maybe I start from scratch I think. thanks
ascotta (Vendor)
8 Jul 05 7:04
Ah citrix docs, yes the are not very intuiative.

It will be something simple, check that they are allowed to be autocreated in group policy. I will check and let you know where it is.

Oh you know, just doing what I do.

Cheers
Scott

ascotta (Vendor)
8 Jul 05 7:06
Here it is      [thanks to Yardy for posting the link]

Policies

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 7:29
Thanky Scott. That policy was for W2K3 and we are W2K.
I created a simple policy in metaframe PS console for printer. Just enabled "auto create (non-network) client printers only" and got same error.
Strange is that in event viewer/system log, I see first "Printer EPSON AL-C900 Advanced (from WI_y6BkS5PgtYSEDpxvL) in session 1 is pending deletion." and then
"Printer EPSON AL-C900 Advanced (from WI_y6BkS5PgtYSEDpxvL) in session 1 was deleted.".

Maybe TOO fast I didn't see the printer. I didn't touch any thing in terminal server access as no one must use here.

ascotta (Vendor)
8 Jul 05 8:01
It can take some time for the printers to create. Bout 20 to 30 secs.

Oh you know, just doing what I do.

Cheers
Scott

ascotta (Vendor)
8 Jul 05 8:02
For you to see all printers you have to be admin type person/personess.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 8:27
Yes Scott, I am logged on as admin. I am starting from scrath looking at event log step by step. Will keep you informed. PS4 is new and seem like bugs and not much area to search for info either.
novice05 (IS/IT--Management) (OP)
8 Jul 05 9:07
I did not install network file and print service in the window component wizard as we will not have Mac and Unix users. They'll be only using Citrix window environment via web to print. Do you think this is the problem why auto create not working ? Its a new server with PS4. Thanks.
ascotta (Vendor)
8 Jul 05 9:39
I doubt it Citrix don't have the same reputation as you know who for delivering bug ridden software. I have it working no problem on several sites.

Oh you know, just doing what I do.

Cheers
Scott

ascotta (Vendor)
8 Jul 05 9:40
Just had a thought, if you are using web interfaces printing is turned off by default. Look at your Web Interface configuration.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 9:57
Thanks Scott,
On WI in "manage client connection setting" , we allow user to map printer and in Java client, printer mapping is enabled though we will not have java client (hopefully). I had all disabled policies and starting step by step. Will be here whole weekend sweating. .
ascotta (Vendor)
8 Jul 05 10:01
Racking head now!

Oh you know, just doing what I do.

Cheers
Scott

ascotta (Vendor)
8 Jul 05 10:01
I will be here from time to time over weekend. Sad dipstick that I am.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
8 Jul 05 11:55
Thanks Scott. Just back in. Will sweat more, its a challenge.
Have a nice weekend.
novice05 (IS/IT--Management) (OP)
8 Jul 05 13:03
I checked my citrix secure gateway and I see "your metaframe farm is not license to support workspace control" in the event log.
ascotta (Vendor)
11 Jul 05 5:24
That means that you Edition is either Standard or Advanced. Not enterprise. Check in The Management Console as to what Edition your server is set to.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
11 Jul 05 6:33
Scott, you are right. Its standard version only. But should be able to autocreate at least a printer.

I sweated my weekend this stuff and didn't succeed yet. I had done what in admin guide plus I followed/checked steps in:
http://ctxex10.citrix.com/kb/entry.jspa?externalID=CTX106683
http://ctxex10.citrix.com/kb/entry.jspa?externalID=CTX106629
http://ctxex10.citrix.com/kb/entry.jspa?externalID=CTX106393

I have this message in application log of event viewer as below:

Source: metaframeEvents
Event ID 1116
Printer auto-creation failure. Reason: AddPrinter() failed with status 0x5. Client name: (WI_63H8_E_iQAlN0I0jL) Printer name: (EPSON AL-C900 Advanced (from WI_63H8_E_iQAlN0I0jL) in session 1) Port name: (Client:1:EPSON AL-C900 Advanced) Driver name: (EPSON AL-C900 Advanced) Print processor: (WINPRINT)

In the system log is:
Printer EPSON AL-C900 Advanced (from WI_63H8_E_iQAlN0I0jL) in session 3 is pending deletion.
after that :
Printer EPSON AL-C900 Advanced (from WI_63H8_E_iQAlN0I0jL) in session 3 was deleted.

I am also confused in Citrix's MPS4 admin guide's page 325 pointing about auto-create printers (which is written not clear). If auto-create program will create client's directly connected printer, why should I need to add/create printer for client's ? (I know I have to create IF for network printer).
Thanks for the help. I sweat more and at least I'll get to the base of this.
ascotta (Vendor)
11 Jul 05 6:45
You should not need to add a printer for clinets. It should just autocreate. The language is not good.

I describe client printers as either locally attached (Via parallel cable or such like) or created in thir local print manager as a connection to a print device.

Network printers are imported and work like a dream.

You need to have the driveer as described on local print manager. Or you can map them.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
11 Jul 05 7:31
Scott, what do you mean "Language is not good". We use only english on our system. "create in their local print manager as a connection to a print device", can you point to me in which policy shall I look for this? Most of the client's printers are attached by USB. Sorry to ask you? I even think whether to reinstall PS4 but I do not have spare server.
ascotta (Vendor)
11 Jul 05 8:01
No I mean the "Citrix" language.  They don't describe it too well.


Ooooohhhh USB ????? well it should work. Re-install probably wont help you.

I was only explaining what I see as a local printer.

Lets take a printer for example.

Is it attached to the client PC ?

Is the driver that installed on the local PC installed on the Citrix server ?

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
11 Jul 05 9:22
They said its USB (some LPT etc..) and printers are vary from users to users. Sometime its lexmark, Dell and god knows what as they are in different countries. We thought when we read auto-creation is soo great that we gave the idea. :-(
Our aim is to autocreate printer and driver except from prohibit list of printer driver giving trouble that we will add later. Event and error logs doesn't gave much info to see more detail either.
Will keep you inform as I am searching info.

Does anyone have the same problem like me ?
ascotta (Vendor)
11 Jul 05 9:27
I have two sites at persent. One is 2k3 other is 2k.

Both are working OK. In fact I just logged on there to one over the web. And had printers.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
11 Jul 05 9:56
Scott,
I created temporary mailbox at ct003@skynet.be
can you contact me please ?
lb63640 (MIS)
11 Jul 05 10:03
On your W2K server, what service pack are you running?  What are the Event ID numbers from your application and system logs in the event viewer?

We had a rocky start with our Citrix implementation because we were complete newbies and had no resources for help until we blundered into Tek-Tips last year.  Hang in there!
novice05 (IS/IT--Management) (OP)
12 Jul 05 7:46
W2K server is with SP4 and updated with latest patches. Event IDs are 1116 and please look at the above previous threads. I am newbie and learning and documentation is not clear though the product is great.


Scott, where do you see the client's printer attached ?
I use "citrix printer configuration" printcfg.exe and can see printer but cannot connect (that where I got the message "your metaframe farm is not license to support workspace control").
Can you see your client's printer from inside opened program like in Word ?
PS: We do not use program neighbourhood. We gave only webaccess to users. Thanky. J
ascotta (Vendor)
12 Jul 05 8:58
I publish print manager. That is where you see the printers. There is an article on Citrix web site as to how to publish print manager.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
12 Jul 05 10:42
Thanks Scott. As I am using MPS4, I think do not need publish print manager. I have more confusion after reading below that "to add client printers".

To auto-create client printers
In the left pane of the console, under Printer Management, select Printers.
On the Actions menu, select Printer Management > Client Printers, or click on the toolbar.
To add a client printer to the list, click Add.
Type the Client Name and the Printer Name.
Type, or browse for, the Driver name. You can also browse for the Driver Mapping.
Select the printer port from the drop-down list and click OK. The client printer information is downloaded the next time the client device connects to the farm.

Why do we need to add a printer and driver if its autocreation.
There is no USB port to choose in it either. Can I use com port ?

Lucky we have site like yours for us to understand more. We really appreciate and thanks to you all.J
ascotta (Vendor)
13 Jul 05 5:27
Indeed, I don't think you are looking in the right place. I have neveer had to use that client printer bit.

I think what we want to do is to start from something simple and work it through.

Do you have a printer locally attached or is there a PC close by that does.

If you log into citrix on those boxes to a desktop via ICA does it show a Client printer in Print Manager ?

If it does then autocreation is working. If not then we need to look into it further.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
13 Jul 05 5:59
Scott. I have a PC with window XP and a USB printer connected. We only access Citrix through Webinterface. When I log in and open a desktop window, then start/setting/printer, I only see "add printer" and "MS office document image writer".
On the server, error message of "fail to autocreate" as above.
ascotta (Vendor)
13 Jul 05 7:04
Good start Reason I am going this way is to remove any bells and whistles.

It has to be to do with the USB connection.

Do you have any parallel printers in the building you could try ? Just to rule something out.

Oh you know, just doing what I do.

Cheers
Scott

ascotta (Vendor)
13 Jul 05 7:42
Or alternatively, I just installed Acrobat 7 with viewer, and it stoppoed client printers being created.

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
13 Jul 05 7:46
Its all Dell laptop here and really surprise to find there is no LPT port. Finally found a compaq with one and after searching for parallel cable, I tested it and found the same result though I can print directly without using citrix. I see everyone can auto create printer except me. We do have all PC with norton AV. Norton firewall was shutdown during these test.
ascotta (Vendor)
13 Jul 05 8:33
Do you have any policies for printers?

Oh you know, just doing what I do.

Cheers
Scott

novice05 (IS/IT--Management) (OP)
13 Jul 05 8:57
Yes. Inside presentation server console. Client printer auto-creation and legacy client printers are enabled.
Session printer is also enabled.
In the ica-tcp connection / client settings, connect cleint printers at logon, default to main client printer and 'by default, connect only to client's main printer' are checked. This is also for rdp-tcp conection also.
lb63640 (MIS)
13 Jul 05 15:56
Hey, here's another thought.  I stumbled across some other folks have a similar auto-create problem.

On your system, does the domain admin account start the Citrix SMA Service?  These other folks had the CTX_SMAuser account starting the service, and they were getting this same error.

novice05 (IS/IT--Management) (OP)
14 Jul 05 4:02
IB63640. Thanks a million. Its working now. I have to use local system account for starting Citrix SMA service and Citrix Print Manager service. I dont understand why it let this service start by CTX_SMAuser account if not going to be working.
MPS4 was installed as test member server and I moved from test domain to live domain and WOW, this thing must have changed. Thank you again and Thanks to Scott for this great site. J.
lb63640 (MIS)
14 Jul 05 13:22
Glad to know everything worked out for you! :)

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close