INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

interface flapping in Cat3560 and routers

interface flapping in Cat3560 and routers

(OP)
Hi, there, I have a interface flapping issue in my network. 2 Cat3560 is connected through 2 trunk port configured with port-channel. When I shutdown one of port in Vlan100, other 2 ports in the same vlan will flap going up and down and OSPF will lose the neighbor. One thing I notice that is when I shutdown the switch port, on the other side of router, the L1-L2 is still up/up. I think it should be up/down. I have a keepalive setting on the router interface to 1800. Any body can give me some hints here to troubleshoot?
Here is the switch configs.
Building configuration...

Current configuration : 4453 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RCHdmzSW01
!
logging buffered 8192 debugging
!
ip subnet-zero
ip routing
!
no ip domain-lookup
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!         
!
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 999
 switchport trunk allowed vlan 100,200,300,400,600,700
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport access vlan 600
 speed 100
 duplex full
!
interface GigabitEthernet0/2
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/3
 switchport access vlan 600
 speed 100
 duplex full
!         
interface GigabitEthernet0/4
 switchport access vlan 700
 speed 100
 duplex full
!
interface GigabitEthernet0/5
 switchport access vlan 700
 speed 100
 duplex full
!
interface GigabitEthernet0/6
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/7
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/8
 switchport access vlan 100
!         
interface GigabitEthernet0/9
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/10
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/11
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/12
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/13
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/14
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/15
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/16
 switchport access vlan 100
 speed 100
 duplex full
!
interface GigabitEthernet0/17
 speed 100
 duplex full
!
interface GigabitEthernet0/18
!         
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
 switchport access vlan 400
!
interface GigabitEthernet0/28
 switchport access vlan 400
!
interface GigabitEthernet0/29
 switchport access vlan 400
!
interface GigabitEthernet0/30
 switchport access vlan 200
!
interface GigabitEthernet0/31
 switchport access vlan 200
!
interface GigabitEthernet0/32
 switchport access vlan 200
!
interface GigabitEthernet0/33
 switchport access vlan 200
!
interface GigabitEthernet0/34
 switchport access vlan 200
!
interface GigabitEthernet0/35
 switchport access vlan 200
!
interface GigabitEthernet0/36
 switchport access vlan 200
!         
interface GigabitEthernet0/37
 switchport access vlan 200
!
interface GigabitEthernet0/38
 switchport access vlan 200
!
interface GigabitEthernet0/39
 switchport access vlan 200
!
interface GigabitEthernet0/40
 switchport access vlan 200
!
interface GigabitEthernet0/41
 switchport access vlan 200
!
interface GigabitEthernet0/42
 switchport access vlan 200
!
interface GigabitEthernet0/43
 switchport access vlan 200
!
interface GigabitEthernet0/44
 switchport access vlan 200
!
interface GigabitEthernet0/45
 switchport access vlan 500
 speed 100
 duplex full
!
interface GigabitEthernet0/46
 switchport access vlan 500
 speed 100
 duplex full
!
interface GigabitEthernet0/47
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 999
 switchport trunk allowed vlan 100,200,300,400,600,700
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet0/48
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 999
 switchport trunk allowed vlan 100,200,300,400,600,700
 switchport mode trunk
 channel-group 1 mode on
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan100
 ip address 192.168.40.11 255.255.252.0
 no ip redirects
 no ip proxy-arp
 standby 1 ip 192.168.40.1
 standby 1 priority 110
 standby 1 preempt
 standby 1 track Vlan600 20
!         
interface Vlan200
 no ip address
!
interface Vlan600
 ip address 192.168.35.1 255.255.255.0
!
router ospf 7
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
!
!
control-plane
!
!
line con 0
line vty 5 15
!
end

When I shutdown interface gig 0/2, interface gig0/3 and gig0/4 will go down as well and come back online after a while.

Thanks for your help.

RE: interface flapping in Cat3560 and routers

(OP)
The topology is like the following.

                      V100 (192.168.43.0)
              -----------------------------
               |                        |
               |                        |
               |                        |
         |----------|    Trunk      |----------
         |  SW1     |---------------|  SW2    |
          -----------               ----------
           |   |   | V600              | | | V700
           |   |   |                   | | |
           |   |   |-------R1----------- | |
           |   |-----------R2------------- |
           |---------------R3---------------

RE: interface flapping in Cat3560 and routers

What's your IOS version?

RE: interface flapping in Cat3560 and routers

(OP)
What did you suspect? I will confirm the IOS version tomorrow. However, I am leaning toward the Port-channel command. Since it has etherchannel configured and set the mode to "ON", it might cause the spanning-tree loop as per Cisco's Document if the etherchannel is misconfigured.
I saw the spanning-tree on VLAN 600 will do the spanning-tree calculation 2 times when I shut some port belongs to VLAN 600.
I also noticed that some VLAN assignment to the port is not correct, will double-check tomorrow.

Thanks.

RE: interface flapping in Cat3560 and routers

"mode on" only means that you don't use PAgP/LACP for channel negotiation. Make sure both sides are set to "mode on".

And in older IOS image for Catalyst switches, it has bugs in STP/RSTP/MSTP so it'll be good to make sure that all Catalyst switches are running the most up-to-date IOS version (this may not necessarily be the same case for routers).

RE: interface flapping in Cat3560 and routers

(OP)
The IOS is 12.2(20)SE4. c3560-i5-mz.122-20.SE4.bin
BOOT IOS is 12.2(25r)SE.

It is not the latest, but it should be close enough. Any thought?

RE: interface flapping in Cat3560 and routers

Cisco IOS         Date Retired
12.2(20)SE4    12-MAY-2005

I can only find 12.2.25-SEB2 which is the most updated release as of today and which doesn't have any "Software Advisory Notice"....yet.

I suggest you should try upgrading your IOS to the most current version and try again. At least this is what you can do at this moment.

RE: interface flapping in Cat3560 and routers

(OP)
It is a bug in the IOS, Thanks. I got the TAC confirmed from Cisco

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close