Smart questions
Smart answers
Smart people
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Donate Today!

Do you enjoy these
technical forums?
Donate Today! Click Here

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

tcpserver: fatal: unable to figure out port number for smtpHelpful Member! 

MiniMe001 (Programmer) (OP)
4 Mar 05 15:54
tcpserver: fatal: unable to figure out port number for smtp
/usr/local/bin/tcpserver: error while loading shared libraries: libc.so.6: failed to map segment from shared object: Cannot allocate memory

I've got tons of that in /var/log/qmail/smtpd/current
I used Dave's Life with qmail to install.

======>
I ran this:

#!/usr/bin/perl -w
print +(getservbyname("smtp","tcp"))[2],"\n";

and it turned up 25.

======>
I'm pretty sure I got all the users set up:

qmaild:x:503:1338::/var/qmail:/bin/bash
qmaill:x:504:1338::/var/qmail:/bin/bash
qmailp:x:505:1338::/var/qmail:/bin/bash
qmailq:x:506:1339::/var/qmail:/bin/bash
qmailr:x:507:1339::/var/qmail:/bin/bash
qmails:x:508:1339::/var/qmail:/bin/bash

======>
I ran this by hand to see that it turned up right:

[root@jumpfrog skara]# QMAILDUID=`id -u qmaild`
[root@jumpfrog skara]# NOFILESGID=`id -g qmaild`
[root@jumpfrog skara]# echo $QMAILDUID
503
[root@jumpfrog skara]# echo $NOFILESGID
1338

======>
I changed this line in /var/qmail/supervise/qmail-smtpd/run:
exec /usr/local/bin/softlimit -m 2000000 \

to this:
exec /usr/local/bin/softlimit -m 20000000 \

==========
I can't figure out what the hell is wrong. :/  Any clues?
Helpful Member!  thedaver (IS/IT--Management)
4 Mar 05 17:42
If you used LwQ you should have a qmail-smtpd/run file that contains little text "0 smtp" near the end.

That statement says to use the lookup from /etc/services to decide on the port for tcpserver to monitor.

As a way to convince yourself that the services lookup isn't broken (which your perl script attempts) please go ahead and change this to "0 25" instead.

Give the tcpserver a kick and see if it behaves better.

Internet Directory
http://dir.surfinbox.com/dir.php/Top

MiniMe001 (Programmer) (OP)
4 Mar 05 18:12
hah--works! alright, thanks!
(at least I'm assuming that's what this means):
@400000004228e92f2f8d35cc tcpserver: status: 1/20
@400000004228e92f2f8d4d3c tcpserver: pid 5082 from 64.233.170.203
@400000004228e92f395596e4 tcpserver: ok 5082 removed.net:192.168.1.101:25 rproxy.gmail.com:64.233.170.203::53462
@400000004228e93018a63fd4 tcpserver: end 5082 status 0
@400000004228e93018a65744 tcpserver: status: 0/20

Apparently I'm still doing something wrong, though, as it's not writing the email to the file.. ^^;
Would it be something to do with my .qmail file?  I never did quite understand the mbox/maildir thing.

removed@gmail.com
/home/skara/Mailbox
thedaver (IS/IT--Management)
4 Mar 05 23:29
mbox is single-file based.  maildir is directory based.  

Internet Directory
http://dir.surfinbox.com/dir.php/Top

MiniMe001 (Programmer) (OP)
5 Mar 05 0:44
...ah, simple as that, eh? ^^; thanks.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close