Smart questions
Smart answers
Smart people
Join Tek-Tips Forums
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Member Login




Remember Me
Forgot Password?
Join Us!

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips now!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

Join Tek-Tips
*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.
Jobs from Indeed

Link To This Forum!

Partner Button
Add Stickiness To Your Site By Linking To This Professionally Managed Technical Forum.
Just copy and paste the
code below into your site.

"AddRoute failed to add a route: code 87"

Frylock (TechnicalUser) (OP)
3 Mar 05 11:18
Clients are unable to access network resources after connecting to PIX 501 VPN
The log on the client shows:
1      18:07:21.561  03/02/05  Sev=Warning/2    CVPND/0xE3400014

AddRoute failed to add a route: code 87
    Destination    208.250.55.130
    Netmask    255.255.255.255
    Gateway    192.168.2.1
    Interface    192.168.2.3

2      18:07:21.801  03/02/05  Sev=Warning/3    CM/0xA3100028
Failed to add route from public interface to secure gateway.

3      18:07:21.811  03/02/05  Sev=Warning/3    CM/0xA3100024
Failed to increment route metric to default gateway.

4      18:09:01.084  03/02/05  Sev=Warning/3    IKE/0xE3000065
Could not find an IKE SA for 192.168.2.255.  KEY_REQ aborted.

5      18:09:01.084  03/02/05  Sev=Warning/2    IKE/0xE3000099
Failed to initiate P2 rekey: Error dectected (Initiate:176)

6      18:09:01.084  03/02/05  Sev=Warning/2    IKE/0xE3000099
Unable to initiate QM (IKE_MAIN:422)


The current config on the PIX:
PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password V4mjwuaoG2IOiI.4 encrypted
passwd V4mjwuaoG2IOiI.4 encrypted
hostname UMDF-PIX
domain-name umdf.local
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
names
name 192.168.2.0 VPN2
access-list acl_out permit icmp any any
 
access-list acl_in permit icmp any any
access-list acl_in permit ip any any
access-list 100 permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list 100 permit ip any 192.168.1.0 255.255.255.240
access-list outside_cryptomap_dyn_50 permit ip any 192.168.1.0 255.255.255.240
pager lines 24
logging on
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.xxx 255.255.255.224
ip address inside 192.168.0.254 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 192.168.1.1-192.168.1.10
ip local pool VPN2 192.168.2.1-192.168.2.10
pdm location 192.168.0.1 255.255.255.255 inside
pdm location 192.168.0.102 255.255.255.255 inside
pdm location 66.219.161.192 255.255.255.240 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.0.101 255.255.255.255 inside
pdm location VPN2 255.255.255.0 outside
pdm logging errors 100
pdm history enable
arp timeout 14400
global (outside) 1 xxx.xxx.xxx.xxx
nat (inside) 0 access-list 100
nat (inside) 1 192.168.0.0 255.255.255.0 0 0
static (inside,outside) 208.250.55.131 192.168.0.102 netmask 255.255.255.255 0 0
static (inside,outside) 208.250.55.132 192.168.0.1 netmask 255.255.255.255 0 0
static (inside,outside) 208.250.55.133 192.168.0.101 netmask 255.255.255.255 0 0
access-group acl_out in interface outside
access-group acl_in in interface inside
route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set VPNset esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map dynmap 10 set transform-set VPNset
crypto dynamic-map dynmap 30 set transform-set ESP-3DES-SHA
crypto dynamic-map dynmap 50 match address outside_cryptomap_dyn_50
crypto dynamic-map dynmap 50 set transform-set ESP-3DES-SHA
crypto dynamic-map inside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map VPNmap 10 ipsec-isakmp dynamic dynmap
crypto map VPNmap interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic inside_dyn_map
crypto map inside_map interface inside
isakmp enable outside
isakmp enable inside
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption 3des
isakmp policy 30 hash sha
isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
vpngroup UMDF address-pool VPN
vpngroup UMDF dns-server 192.168.0.1 205.171.3.65
vpngroup UMDF default-domain umdf.local
vpngroup UMDF split-tunnel 100
vpngroup UMDF idle-time 7200
vpngroup UMDF password ********
vpngroup UMDF2 address-pool VPN2
vpngroup UMDF2 dns-server 192.168.0.1 205.17.3.65
vpngroup UMDF2 default-domain umdf.local
vpngroup UMDF2 idle-time 1800
vpngroup UMDF2 password ********
vpngroup UMDF3 address-pool VPN
vpngroup UMDF3 dns-server 192.168.0.1 205.171.3.65
vpngroup UMDF3 default-domain umdf.local
vpngroup UMDF3 split-tunnel outside_cryptomap_dyn_50
vpngroup UMDF3 idle-time 1800
vpngroup UMDF3 password ********
telnet 192.168.0.0 255.255.255.0 inside
telnet timeout 5
ssh 66.219.161.192 255.255.255.240 outside
ssh timeout 5
terminal width 80
Cryptochecksum:7be8cdb8cfbfbc060c93ab07da3f4600
: end
[OK]

While troubleshooting this I have NAT'ed global to an IP different from the interface, set up different IP pools, and tried to add the "isakmp nat-traversal" command (which I could not get to work)

 
Ckoslow (IS/IT--Management)
16 Mar 05 9:42
you get anymore information on this. I have the first error but everything works for me.  Heres the error I receive

AddRoute failed to add a route: code 87
    Destination    192.168.1.255
    Netmask    255.255.255.255
    Gateway    192.168.2.1
    Interface    192.168.2.1

Any thoughts?

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Back To Forum

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close