INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

SRST Routers Config

How to setup GW, DHCP, SRST, QOS, Dail-peer and more by jeter
Posted: 6 Mar 08

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname Main_3845
!
boot-start-marker
boot-end-marker
!
card type t1 0 1
card type t1 0 2
card type t1 0 3
card type t1 1 0
card type t1 1 1
logging buffered 4096 debugging
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
network-clock-participate wic 1
no network-clock-participate wic 2
no network-clock-participate wic 3
network-clock-select 1 T1 0/1/0
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.2.21.1 10.2.21.10
ip dhcp excluded-address 10.2.21.245 10.2.21.254
!
ip dhcp pool Voice
   network 10.2.21.0 255.255.255.0
   option 150 ip 10.2.21.1 10.2.21.2
   default-router 10.2.21.254
!
!
no ip domain lookup
!
isdn switch-type primary-ni
voice-card 0
 no dspfarm
!
!
!
trunk group  SRST
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2347448322
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2347448322
 revocation-check none
 rsakeypair TP-self-signed-2347448322
!
!
crypto pki certificate chain TP-self-signed-2347448322
 certificate self-signed 01
  30820242 308201AB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32333437 34343833 3232301E 170D3037 30373136 30353039
  32385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 33343734
  34383332 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A5DD 25B2C642 FA6CD5A9 FC026D78 85CBF143 8D8D1060 56155AD9 C7717DB8
  6F7D1D3A 9A7E1FEE 5B54B897 A6E1AB4B D7B1BEF6 76BCBCD0 C3D386FD CA9B34BC
  ECF7B310 031DD036 33BC725B 8C0894C7 AE8A6F8C 6DC7E1D1 634C98C4 BAAF7F31
  997265D6 B0914905 B30A731A 11C4ED89 1A4EE97B 2A76BB18 8E0F134C 029DB1B9
  C3BF0203 010001A3 6A306830 0F060355 1D130101 FF040530 030101FF 30150603
  551D1104 0E300C82 0A4D6169 6E5F3338 34352E30 1F060355 1D230418 30168014
  E79A005A 598E3803 12F81C09 A8DCC144 DF0D1877 301D0603 551D0E04 160414E7
  9A005A59 8E380312 F81C09A8 DCC144DF 0D187730 0D06092A 864886F7 0D010104
  05000381 81008CE0 B446AC2B F35C79CA AE4B9EB6 C7651697 BB457314 17BC2893
  74F0B4EA DA1636D0 4498EFC5 E431F94A 42BF10A9 A6104FC8 539996CD 3928D1C9
  512938AB B52E4E30 99018997 8247288E E98B6095 2C580F19 7EDC03D7 4801AE61
  427446DA 0AAE3DFA BD85620D 068CE362 B14B31CB 964DBAEF 97577EA9 4C9269AD
  4F752B4E E6EF
  quit
username cisco privilege 15 password cisco
!
!
controller T1 0/1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/1/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/2/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
controller T1 0/2/1
 framing esf
 linecode b8zs
 channel-group 1 timeslots 1-24
!
controller T1 0/3/0
 framing esf
 linecode b8zs
 channel-group 2 timeslots 1-24
!
controller T1 0/3/1
 framing esf
 linecode b8zs
 channel-group 3 timeslots 1-24
!
controller T1 1/0/0
 framing esf
 linecode b8zs
 channel-group 4 timeslots 1-24
!
controller T1 1/0/1
 framing esf
 linecode b8zs
 channel-group 5 timeslots 1-24
!
controller T1 1/1/0
 framing esf
 linecode b8zs
 channel-group 6 timeslots 1-24
!
controller T1 1/1/1
 framing esf
 linecode b8zs
 channel-group 7 timeslots 1-24
!
class-map match-all VoIP
 match access-group name VoIP
class-map match-all Network_Critical
 match access-group name Network_Critical
class-map match-all VoIP_Control
 match access-group name VoIP_Control
!
!
policy-map WAN
  description *** Policy Map for T1 ***
 class VoIP
  priority 768
 class Network_Critical
  bandwidth percent 3
  set precedence 4
 class VoIP_Control
  bandwidth percent 3
 class class-default
  fair-queue
  random-detect
policy-map Set-Data-DSCP
  description *** Policy map to set DSCP values of data packets to 0 ***
 class class-default
  set dscp default
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.0.1.254 255.255.0.0
 no snmp trap link-status
!
interface GigabitEthernet0/0.200
 description Subinterface For Voice Network
 encapsulation dot1Q 200
 ip address 10.2.21.254 255.255.255.0
 no snmp trap link-status
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface Serial0/1/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/1/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/2/0:0
 description Backup T-1 To remote 1
 ip address 192.168.1.1 255.255.255.252
 service-policy output WAN
!
interface Serial0/2/1:1
 description Backup T-1 to remote 2
 ip address 192.168.3.1 255.255.255.252
 service-policy output WAN
!
interface Serial0/3/0:2
 description Backup T-1 to remote 3
 ip address 192.168.4.1 255.255.255.252
 service-policy output WAN
!
interface Serial0/3/1:3
 description Backup T-1 to Remote 4
 ip address 192.168.5.1 255.255.255.252
 service-policy output WAN
!
interface Serial1/0/0:4
 description Backup T-1 to remote 5
 ip address 192.168.6.1 255.255.255.252
 service-policy output WAN
!
interface Serial1/0/1:5
 description Backup T-1 to remote 6
 ip address 192.168.7.1 255.255.255.252
 service-policy output WAN
!
interface Serial1/1/0:6
 description Backup T-1 to remote 7
 ip address 192.168.8.1 255.255.255.252
 service-policy output WAN
!
interface Serial1/1/1:7
 no ip address
!
router eigrp 1
 redistribute static
 network 10.0.0.0 0.0.255.255
 network 10.2.21.0 0.0.0.255
 network 192.168.1.0 0.0.0.3
 network 192.168.2.0 0.0.0.3
 network 192.168.3.0 0.0.0.3
 network 192.168.4.0 0.0.0.3
 network 192.168.5.0 0.0.0.3
 network 192.168.6.0 0.0.0.3
 network 192.168.7.0 0.0.0.3
 network 192.168.8.0 0.0.0.3
 network 192.168.9.0 0.0.0.3
 distribute-list 1 out static
 no auto-summary
 no eigrp log-neighbor-warnings
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.1.102
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip access-list extended Network_Critical
 remark ****Network Critical - Telnet, NTP, etc *****
 permit ip any any precedence internet
ip access-list extended VoIP
 remark ****Voip RTP and control traffic ****
 permit ip any any dscp ef
 permit ip any any precedence critical
ip access-list extended VoIP_Control
 remark **** VoIP control traffic ****
 permit ip any any dscp cs5
 permit ip any any precedence flash
!
access-list 1 permit 0.0.0.0
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0:23
!
voice-port 0/1/1:23
!
ccm-manager redundant-host 10.2.21.1
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.2.21.1 10.2.21.2
ccm-manager config
!
mgcp
mgcp call-agent 10.2.21.2 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
!
!
dial-peer voice 1 pots
 incoming called-number .
!
 dial-peer voice 10 pots
 trunkgroup SRST
 description 911 Dialing
 destination-pattern 9911
 forward-digits 3
!
dial-peer voice 11 pots
 trunkgroup SRST
 description 911 Dialing
 destination-pattern 911
 forward-digits all
!
dial-peer voice 12 pots
 trunkgroup SRST
 description Local Dialing
 destination-pattern 9[2-9]......
!
dial-peer voice 13 pots
 trunkgroup SRST
 description Local 10 Digit Dialing
 destination-pattern 9[2-9]..[2-9]......
 forward-digits 10
!
 dial-peer voice 14 pots
 trunkgroup SRST
 description Long Distance Dialing
 destination-pattern 91[2-9]..[2-9]......
 forward-digits 11
!
dial-peer voice 15 pots
 trunkgroup SRST
 description International Dialing
 destination-pattern 9011T
 prefix 011
!
!
!
!
call-manager-fallback
 secondary-dialtone 9
 max-conferences 12 gain -6
 limit-dn 7940 1
 limit-dn 7960 1
 limit-dn 7970 1
 ip source-address 10.2.21.254 port 2000
 max-ephones 100
 max-dn 200
 transfer-pattern 9T
 transfer-pattern ....
 call-forward pattern 9T
 call-forward pattern ....
!
banner motd ^C
*************  ATTENTION  ATTENTION  ATTENTION  ***********
    Main_3845 router all unauthorized access is logged.

*********REDISTRIBUTING DEFAULT ROUTE VIA EIGRP************
^C
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 privilege level 14
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 14
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Back to Cisco: Call Manager FAQ Index
Back to Cisco: Call Manager Forum

My Archive

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close