INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

Gateway Router w/PRIs Config

How to setup a Gateway router w/ PRIs and MGCP by jeter
Posted: 6 Mar 08

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname PRI_GW
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.99.1 192.168.99.10
ip dhcp excluded-address 192.168.99.250 192.168.99.254
!
ip dhcp pool Phones
   network 192.168.99.0 255.255.255.0
   option 150 ip 192.168.99.250
   default-router 192.168.99.254
!
!
no ip domain lookup
!
isdn switch-type primary-dms100
!
voice-card 0
 no dspfarm
!
!
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
!
voice class h323 1
 h225 timeout tcp establish 3
!
!
!
!
!
!

username cisco privilege 15 password cisco
!
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 0/0/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.1
 shutdown
!
interface GigabitEthernet0/0.2
 description Voice VLAN
 encapsulation dot1Q 2
 ip address 192.168.99.254 255.255.255.0
 no snmp trap link-status
!
interface GigabitEthernet0/0.79
 description Native Data Vlan
 encapsulation dot1Q 79
 ip address 192.168.79.254 255.255.255.0
 no snmp trap link-status
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 isdn switch-type primary-dms100
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/0/1:23
 no ip address
 isdn switch-type primary-dms100
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip classless
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/0/1:23
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
 timing hookflash-out 500
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 192.168.99.250
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 192.168.99.250  
ccm-manager config
!
mgcp
mgcp call-agent 192.168.99.251 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0.2
mgcp bind media source-interface GigabitEthernet0/0.2
!
mgcp profile default
!
!
!
dial-peer voice 999033 pots
 service mgcpapp
 port 0/3/3
!
!
!
!
line con 0
 logging synchronous
 login local
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

Back to Cisco: Call Manager FAQ Index
Back to Cisco: Call Manager Forum

My Archive

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close