INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Jobs

TCP/IP Troubleshooting

Troubleshoot & Reinstall Winsock - WinXP by Networker1
Posted: 2 Jun 04

Problem: You have a PC that can ping nodes on the local network but can not surf the web. You have checked your browsers settings and security and have set them back to default but the problem persists, you have also uninstall the network adapter and reintalled it but still no comm. After all this you even downloaded all your browsers libraries [this is another FAQ Q&A] and re-installed and nothing.

Solution: Go to Run > regedit > and delete the following

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2

Restart the computer
Go to Network Connections
Right click and select Properties
Click on the Install button
Select Protocol
Click on the Add  button
Click on the Have Disk button
Go to the \Windows\inf directory
Select anything there and click Open
Highlight Internet Protocol (TCP/IP)
Click on the OK button
Check to see if your network adapter obtained a new IP lease and if not...
Reboot

Back to TCP/IP FAQ Index
Back to TCP/IP Forum

My Archive

Resources

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close